Es kann keine Verbindung zu FTP über Filezilla in Lightsail hergestellt werden

299
sirDexter

Ich habe eine Instanz von Debian auf Amazon Lightsail erstellt. Alles funktioniert gut, außer FTP. Ich habe Port 21 zur Firewall hinzugefügt: Port 21 hinzugefügt

Als Nächstes folgte ich diesen Anweisungen zu dem Schreiben, wie Proftpd installiert wird: https://www.tecmint.com/install-proftpd-in-ubuntu-and-debian/

Als letzten Schritt habe ich dem proftpd-Benutzer ein Kennwort hinzugefügt und den Dienst neu gestartet. Dann wurde eine FTP-Verbindung in Filezilla mit den folgenden Daten hinzugefügt: FileZilla-Daten

Und ich erhalte folgende Fehlermeldung:

falsche Daten

Benutzt jemand ftp mit Lightsail?

1
Warum FTP? Tun Sie sich einen Gefallen mit SFTP. Wenn Sie dies bemerken, zeigt das Protokoll * Login falsch * an, daher würde ich von dort starten. Überprüfen Sie die Protokolle auf dem Server. Bitte beachten Sie, dass FTP auch Datenports benötigt. simlev vor 2 Jahren 0

1 Antwort auf die Frage

0
simlev

Frage:

Benutzt jemand ftp mit Lightsail?

Antwort: Wahrscheinlich nicht.

Erläuterung: FTP ist ein sehr altes Protokoll, das einige Nachteile hat (verwendet zufällige Ports, keine Verschlüsselung ...). Lightsail wurde 2016 ins Leben gerufen, als die meisten Unternehmen bereits von FTP zu FTPS oder SFTP gewechselt waren. Es gibt immer noch Anwendungsfälle für FTP, aber ich bezweifle, dass viele es verwenden würden, um mit ihren Servern zu kommunizieren, die auf einem Dienst wie Lightsail gehostet sind.


Wenn das Ziel ist, WordPress-Plugins zu aktualisieren, empfehle ich die Verwendung von wp-cli, anstatt einen FTP-Server einzurichten.

Ich verwende SFTP, um Dateien über FileZilla zu übertragen. Ich habe Sites in WordPress und kann Plugins über FTP oder FTPS aktualisieren. Ich habe FTP für OVH verwendet. Ich werde stattdessen versuchen, FTPS zu konfigurieren. Vielen Dank. sirDexter vor 2 Jahren 0
@sirDexter Warum nicht SFTP? simlev vor 2 Jahren 0
In WordPress gibt es nur zwei Verbindungstypen zum Aktualisieren von Plugins: 1. FTP 2. FTPS (SSL) sirDexter vor 2 Jahren 0
Mit [wp-cli] (https://wp-cli.org/) aktualisieren Sie WordPress-Plugins. simlev vor 2 Jahren 0
Vielen Dank für die großartige Alternative, die mir nicht bewusst war. sirDexter vor 2 Jahren 0