Lua kann nicht auf Mac 10.6.4 installiert werden

905
TokyoDan

Ich habe MacPorts erfolgreich auf Mac 10.6.4 installiert, lua kann jedoch nicht installiert werden. Ich weiß, dass MacPorts installiert ist, da ich von meinem Administratorkonto aus "Port Selfupdate" und "Port Search Lua" erfolgreich ausführen kann. Wenn ich jedoch 'sudo port install lua' ausführe, erhalte ich Fehler:

---------------------------------------------------------------------------- bash-3.2$ sudo port install lua ---> Computing dependencies for lua ---> Dependencies to be installed: readline ncurses ncursesw ---> Configuring ncursesw Error: Target org.macports.configure returned: configure failure: shell command failed Log for ncursesw is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_ncursesw/main.log Error: The following dependencies failed to build: readline ncurses ncursesw Error: Status 1 encountered during processing. To report a bug, see <http://guide.macports.org/#project.tickets> bash-3.2$  ---------------------------------------------------------------------------- 

Was mache ich falsch? Oder nicht genug davon?

1
Die Frage wurde einfach auf die Titelseite gestoßen. Bitte geben Sie eine eigene Antwort ("Entwickler-Tools installieren") ein und akzeptieren Sie sie, damit diese Frage als beantwortet betrachtet werden kann. Daniel Beck vor 10 Jahren 0

1 Antwort auf die Frage

0
fideli

Es ist nicht möglich zu sehen, was allein durch diese Nachricht schief gelaufen ist. Die Installation von Port ncursesw war bisher nicht erfolgreich. Führen Sie sudo port clean ncurseswdie Ausgabe von aus und speichern Sie sie sudo port -d configure ncursesw. Das -dist für Debugging und enthält alle Informationen hinter den Kulissen zum Erstellen eines Ports. Es könnte zu lang sein, um hier zu posten, aber es wäre hilfreich zu sehen, welcher Shell-Befehl für Sie fehlgeschlagen ist.

Vielen Dank. Ich habe das Problem behoben. Ich habe xcode neu installiert und die UNIX-Entwicklungstools hinzugefügt, die ich zuvor nicht installiert habe. TokyoDan vor 11 Jahren 0
Großartig. Gut zu hören. fideli vor 11 Jahren 0