Es kann keine Verbindung zum LAN-Port hergestellt werden, wenn das System eine Verbindung zu einem WLAN-Router in einem anderen Subnetz herstellt

446
Vishal

Ich habe also PC1, der über LAN wie folgt mit dem Router verbunden ist, während der WLAN-Adapter deaktiviert bleibt.

PC1-LAN-Adapter:
Statische IP- Adresse : 192.168.1.20
Subnetz: 255.255.255.0
Gateway: 192.168.1.1
DNS-Server: 8.8.8.8

Deaktivierter PC1-WLAN-Adapter:
Statische IP: 192.168.45.5
Subnetz: 255.255.255.0
Gateway:
DNS-Server: 8.8.8.8

Auf diesem PC1 laufen mehrere Netzwerkserver, auf die andere Knoten im Netzwerk 192.168.1.0/24 zugreifen können.

Manchmal, wenn das Internet auf dem Router ausfällt, habe ich PC1 mit dem Internet-Hotspot meines Handys verbunden, indem der WLAN-Adapter wie folgt aktiviert wird:

PC1-WLAN-Adapter:
Statische IP: 192.168.45.5
Subnetz: 255.255.255.0
Gateway: 192.168.45.1
DNS-Server: 8.8.8.8

Während dieser Zeit habe ich den PC1-LAN-Adapter wie folgt eingestellt:
Statische IP: 192.168.1.20
Subnetz: 255.255.255.0
Gateway:
DNS-Server: 8.8.8.8

Das Problem ist, sobald ich PC1 mit dem WLAN-Router meines Telefons verbinde, wird der LAN-Port des PC1 nicht mehr zugänglich, und keiner der anderen Knoten im Netzwerk 192.168.1.0/24 kann auf die Netzwerkserver-Software zugreifen, die auf PC1 ausgeführt wird und über dessen 192.168 verfügbar ist .1.20 IP-Adresse!

Ich habe über das Einrichten von Automatic Metric auf Manual gelesen ... und ich habe dem WiFi-Adapter von PC1 und dem LAN-Adapter von PC1 1 zugewiesen, selbst dann kann ich nicht auf 192.168.1.20 von anderen Knoten im Netzwerk zugreifen.

Pls Führer! Vielen Dank.

0
Unklar. Sind Ihre Adaptereinstellungen statisch oder DHCP? Welcher Prozess entfernt das Standard-Gateway aus dem LAN, wenn Sie eine WLAN-Verbindung herstellen? Gibt es statische Routen? Akina vor 3 Jahren 0
Hallo Akina, ich habe schon erwähnt, dass alle IPs statisch sind. Ich verwende nirgendwo DHCP und aktualisiere diese Einstellungen manuell. Vishal vor 3 Jahren 0
Wenn beide Adaptern mit ihren Einstellungen wie gezeigt aktiviert sind, MUSS der Zugriff auf die LAN-Schnittstelle von jedem Knoten aus 192.168.1.0/24, der an den LAN-Port (über einen Switch) angeschlossen ist, direkt wegen des gleichen Subnetzes erfolgen. Wenn nicht, stimmt der IP-Stack Ihrer Station nicht (beschädigte Firewall?) ... oder es gibt Fakten, die dort nicht veröffentlicht werden. Akina vor 3 Jahren 0
Vielen Dank für Ihre Antwort. Akina .. Nun, der IP-Stack scheint nicht beschädigt zu sein, da ich noch nie einen Fehler in Bezug auf die Netzwerkkonfiguration oder andere Funktionen als dieses festgestellt habe. Außerdem habe ich alle oben genannten Fakten mitgetheilt. Sobald Das WLAN wird verbunden, der LAN-Anschluss wird über mein Verständnis hinaus unzugänglich. Es ist wirklich rätselhaft, dies zu sehen. Wirklich kann ich nicht verstehen, was den LAN-Anschluss unzugänglich macht, wenn der WLAN-Anschluss mit dem Hotspot verbunden wird! Vishal vor 3 Jahren 0
Bitte senden Sie die Ausgaben 'IPCONFIG / ALL' und 'ROUTE PRINT' anstelle des kurzen Einstellungsberichts in eine Frage, wenn beide Adapter aktiviert sind. Akina vor 3 Jahren 0

0 Antworten auf die Frage