Neue Fragen mit dem Tag «apt-get»

Insgesamt gefunden 339 Fragen

-1
Bewertungen
0
Antworten
137
Ansichten

Wie löse ich diesen Abhängigkeitsfehler bei der Installation von GIMP?

Ich versuche GIMP mit apt-get installUbuntu 18.04.1 zu installieren . Es erzeugt einen Abhängigkeitsfehler: $ sudo apt-get install gimp Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have requeste...
fragte Darien Marks vor 2 Jahren

0
Bewertungen
1
Antwort
159
Ansichten

Debian Wheezy, apt-get haben ungelöste Abhängigkeiten

So ziemlich jeder Befehl, den ich versuche, apt-getgibt mir einen Fehler, der mir sagt, dass ich laufen soll apt-get -f install, aber das gibt mir diesen Fehler: root@vps148794:~# apt-get -f install Reading package lists... Done Building dependency tree Reading state information... Done Correcting d...
fragte Saturnix vor 2 Jahren

0
Bewertungen
1
Antwort
178
Ansichten

Ich verwende Darwin OS auf dem Terminal, kann jedoch nicht den Befehl apt-get, yum verwenden (nur das Aufbrühen ist möglich).

Ich verwende Terminal auf Darwin OS aber nicht verwenden kann apt-getund yumBefehle (nur brewverwendbar ist). Irgendwann muss ich verwenden apt-get(zB um Linux Essential Header zu installieren) Aber mein Terminal sagt command not found Was soll ich dafür tun?

-3
Bewertungen
0
Antworten
171
Ansicht

Fehler beim Update von apt-get

apt-get update Get:1 http://ftp.yzu.edu.tw/Linux/kali kali-rolling InRelease [30.5 kB] Get:1 http://ftp.yzu.edu.tw/Linux/kali kali-rolling InRelease [30.5 kB] Reading package lists... Done E: Release file for http://http.kali.org/kali/dists/kali-rolling/InRelease is not valid yet (invalid for anothe...
fragte Ankush Tomar vor 2 Jahren

1
Bewertungen
1
Antwort
98
Ansichten

Programme können nicht entfernt werden

Ich muss einige Programme in meiner Deepin-Distribution entfernen, erhalte jedoch diese Fehlermeldung: amr@amr-PC:~$ sudo apt-get autoremove Virtual Network Editor [sudo] Mot de passe de amr :  E: Impossible d'obtenir le verrou /var/lib/dpkg/lock - open (11: Ressource temporairement non di...
fragte Amr Ch vor 2 Jahren

0
Bewertungen
0
Antworten
165
Ansichten

apt-get Upgrade funktioniert nach dem Upgrade von Stable auf Testing nicht: Fehlerzyklus mit Paket libc-bin

Ich habe ein Upgrade von Debian Stable auf Debian Testing durchgeführt und kann es jetzt nicht apt-get upgrademehr. Wenn ich das tue, erhalte ich diesen Fehler: Processing triggers for libc-bin (2.27-6) ... dpkg: cycle found while processing triggers: chain of packages whose triggers are or may be r...
fragte Giacomo Masseroni Chiaro vor 2 Jahren

1
Bewertungen
1
Antwort
156
Ansichten

apt-get "Paket konnte nicht gefunden werden" mit einem Glob

Ich versuche den Pantheon-Desktop zu deinstallieren. Ich benutze einen Sternenkugel, um alle Pakete zu deinstallieren, deren Name mit "pantheon-" beginnt. rolf@DRGMC01:~$ sudo apt-get remove pantheon-* Reading package lists... Done Building dependency tree Reading state information... Done E: Unabl...
fragte Rolf vor 2 Jahren

0
Bewertungen
1
Antwort
150
Ansichten

Wie kopiere ich alle installierten Bibliotheken auf einen anderen Linux-Rechner?

Ich entwickle C ++ auf einem Linux-Computer (Ubuntu) und habe viele Bibliotheken sowohl durch Verwendung apt-getals auch vom Quellcode aus installiert. Nehmen wir an, ich möchte meine Umgebung auf einem anderen (neu installierten) Linux-Computer (gleiche Version / gleiche Distribution) neu erstellen...

0
Bewertungen
1
Antwort
158
Ansichten

Die neueste Version von Grafana kann nicht mit apt-get installiert werden

Ich habe Probleme bei der Installation von Grafana mit apt-get. Ich befolge diese Anweisungen: http://docs.grafana.org/installation/debian/#apt-repository Ich fügte das Repository hinzu und lief apt-get update & apt-get install grafana. Was ich installiert habe, war die alte Version 2.6.0. Ich h...
fragte saikon vor 2 Jahren

0
Bewertungen
1
Antwort
147
Ansichten

Warum versucht "apt-get purge" weiterhin, Dinge für mich zu installieren?

Ich versuche, das Oracle Java 8-JDK auf Raspbian Stretch zu löschen: sudo apt-get purge oracle-java8-jdk Aber es wird ständig versucht, Ersatz für mich zu installieren. Zum Beispiel sagt es mir immer "die folgenden NEUEN Pakete werden installiert": ca-certificates-java default-java-plugin default-j...
fragte Nick Lee vor 2 Jahren

1
Bewertungen
1
Antwort
1627
Ansichten

Debian Apt Update erlaubt keine DVDs

Ich fange wirklich an, mir die Haare auszureißen. Ich habe ein Debian-9-System ohne Internetzugang und versuche, ein passendes Update durchzuführen. Ich erhalte jedoch immer die gleiche Fehlermeldung (siehe unten). Ich habe mehrere Optionen ausprobiert, um unsichere Repositorys zuzulassen, aber nich...
fragte Steffen S. vor 2 Jahren

0
Bewertungen
0
Antworten
112
Ansichten

Entfernen Sie die in apt-cache aufgeführten gdal-Pakete

Bei einer fehlerhaften Installation kann gdalich das sf RPaket nicht in meiner Standardumgebung installieren conda(siehe https://stackoverflow.com/a/51369036/1840471 ). Ich versuche alle Nicht-Conda- gdalPakete zu entfernen, habe aber Schwierigkeiten. Ich habe diese Befehle bereits ausgeführt: sudo...
fragte Max Ghenis vor 2 Jahren

0
Bewertungen
1
Antwort
999
Ansichten

Fehler beim Abrufen des Fehlers bei apt-get Update

Ich habe ein Problem beim Laufen sudo apt-get update. Ich bekomme immer diesen Fehler: Err:1 https://deb.packager.io/gh/opf/openproject-ce xenial InRelease Could not resolve host: deb.packager.io Hit:2 http://us.archive.ubuntu.com/ubuntu xenial InRelease Hit:3 http://us.archive.ubuntu.com/ubuntu xen...

0
Bewertungen
2
Antworten
509
Ansichten

Konsolen-Setup führt dazu, dass apt-get update nicht mehr reagiert

Ich möchte apache2 beim ersten Laden automatisch auf meiner EC2-Instanz installieren. Ich verwende das Basis-Ubuntu 16.04 LTS-Image: ubuntu/images/hvm-ssd/ubuntu-xenial-16.04-amd64-server-20180522 (ami-a4dc46db) Mein Benutzerdatenskript ist unten: #!/bin/bash apt-get update && apt-get upgra...

1
Bewertungen
1
Antwort
86
Ansichten

Legen Sie ein Ubuntu-Paket für ein späteres Upgrade fest

Beim Ausführen von 'sudo apt-get upgrade' werden manchmal Kernel-Dateien 'zurückgehalten', so dass sie nicht automatisch aktualisiert werden. Gibt es eine Möglichkeit, andere Pakete zu markieren, damit sie in diese Kategorie gelangen? Android-Studio zum Beispiel ist ein umfangreiches Paket, und ich...
fragte ProgAndPlay vor 2 Jahren

0
Bewertungen
1
Antwort
257
Ansichten

Die Firewall von Firewall blockiert die Aktualisierung von Raspbian apt-get

Ich verbinde meinen Himbeer-Pi 3 (Raspbian-Stretch) mit meinem Macpro (10.13.2; High Sierra) mit dem 802.3-Ethernet-Port, der Teil eines überbrückten Adapters ( bridge100) ist, der die Internetfreigabefunktion verwendet. Internetschnittstelle auf dem Mac ist en2(drahtlos). Ich kann zwar pingen googl...

0
Bewertungen
1
Antwort
165
Ansichten

Fehler bei der Installation von "linux-cloud-tools-common" unter Ubuntu 14.04

Ich versuche, Certbot auf einem Ubuntu-Computer einzurichten, erhalte jedoch beim Ausführen folgende Fehlermeldung apt-get install software-properties-common: Setting up linux-cloud-tools-common (3.13.0-46.77) ... start: Job failed to start invoke-rc.d: initscript hv-kvp-daemon, action "start" faile...

0
Bewertungen
1
Antwort
288
Ansichten

Sudo ist defekt oder nicht vollständig installiert

Ja... Ich erhalte diese Fehlermeldung, wenn Sie apt-get mit einem Digitalocean-Droplet verwenden: E: The package sudo needs to be reinstalled, but I can't find an archive for it. Laut dieser Antwort muss ich meinen Server von sudo und allen Verweisen darauf löschen und dann neu installieren? Was fü...
fragte Menasheh vor 3 Jahren

1
Bewertungen
3
Antworten
1716
Ansichten

Wie gehen Sie Schritt für Schritt vor, um die "Folgende Pakete weisen nicht erfüllte Abhängigkeiten" auf?

Ich habe alles versucht, aber keine Fortschritte gemacht. Kann eine kluge Seele helfen? Natürlich klappt einfach sudo apt-get -f installnicht, gleicher Fehler. $ sudo apt-get install arping [sudo] password for dloo: Reading package lists... Done Building dependency tree Reading state information......
fragte chicago-ny vor 3 Jahren

1
Bewertungen
1
Antwort
7783
Ansichten

Das Ausführen von "apt-get update" gibt einen Fehler "apt-secure (8)" zurück.

Ich habe das Ubuntu Game Pack und versuche es zu benutzen sudo apt-get updateund es wird der Fehler behoben W: https://download.01.org/gfx/ubuntu/16.04/main/dists/xenial/InRelease: Signature by key 09D6EF97BFB38E916EF060E756A3DEF863961D39 uses weak digest algorithm (SHA1) W: GPG error: http://deb.pl...
fragte Eno 12345 vor 3 Jahren

3
Bewertungen
3
Antworten
182
Ansichten

Beschleunigung der Installation von apt-get für viele Pakete

Ich habe festgestellt, dass ein Großteil der Zeit, die apt-get installbei der Installation vieler Pakete / Abhängigkeiten benötigt wird, auf viele individuelle Anforderungen für Pakete / Abhängigkeiten zurückzuführen ist, auch wenn der Gesamt-Download möglicherweise nicht groß ist. Ist dies die einz...
fragte user1330734 vor 3 Jahren

1
Bewertungen
2
Antworten
85
Ansichten

So installieren Sie eine Liste von Paketen mit Datei mit Kommentaren

Ich möchte eine große Datei von Abhängigkeiten mit Kommentaren und Zeilenumbrüchen organisieren. Zum Beispiel: # Widget 1 dependences package_a package_b # Widget 2 dependencies package_x package_y package_z Diese Zeile schien sinnvoll zu sein, aber ich verstehe nicht, warum ich die Fehlermeldung...
fragte tarabyte vor 3 Jahren

3
Bewertungen
1
Antwort
3120
Ansichten

Wie installiere ich Clang 4.0 unter Ubuntu 14.04?

Ich muss Clang 4.0 und Clang ++ 4.0 auf meiner Ubuntu 14.04-Box installieren. Die neueste Version, die ich in der apt-get-Paketliste finden kann, ist 3.5. Wie installiere ich 4.0?
fragte Robert Oschler vor 3 Jahren

0
Bewertungen
1
Antwort
205
Ansichten

Nach dem erfolgreichen Erstellen der Docker-Datei verschwindet apt-transport-https

Im Laufe der Zeit habe ich eine unordentliche Docker-Datei für die Erstellung meiner Entwicklerumgebung zusammengestellt, die im Allgemeinen gut funktioniert. Es gibt jedoch einige Situationen, in denen ich etwas während des Docker Builds installiere und es scheint gut zu laufen. Wenn ich jedoch ein...
fragte Alex Edelstein vor 3 Jahren

0
Bewertungen
0
Antworten
551
Ansicht

sudo apt-get funktioniert nicht richtig

Während des Laufens sudo apt-get upgradebekam ich einen Fehler $ sudo apt-get upgrade Reading package lists... Done Building dependency tree Reading state information... Done Calculating upgrade... Done The following packages were automatically installed and are no longer required: linux-headers-4....
fragte codenut vor 3 Jahren

2
Bewertungen
1
Antwort
2004
Ansichten

Aufgrund von Python können KEINE Pakete installiert werden

Ich kann keine Pakete mit installieren apt-get Raspbian (Debian) weil dumme Python-Pakete vorhanden sind. Ich versuchte zu sudo dpkg --configure -a aber auch dann bekomme ich diese Fehler! Mitteilungen: Setting up python3 (3.4.2-2) ... running python rtupdate hooks for python3.4... dpkg-query: packa...
fragte Niall vor 3 Jahren

1
Bewertungen
0
Antworten
1217
Ansichten

Ausführliche Ausgabe für apt-get

Vor einiger Zeit apt-get autocleandruckte jedes Paket, das mit der Größe gelöscht wurde, auf die Konsole. Beispiel: Del gpm 1.19.6-11 [145kB] Diese Zeilen werden nicht mehr gedruckt, aber die Dateien verschwinden immer noch /var/cache/apt/archives. Wie kann ich diese Zeilen immer mit apt-get drucke...
fragte Andrew vor 3 Jahren

0
Bewertungen
1
Antwort
5040
Ansichten

apt-get Nicht erfüllte Abhängigkeiten

Jedes Mal, wenn ich versuche, etwas mit apt-get zu installieren, wird dies zurückgegeben Reading package lists... Done Building dependency tree Reading state information... Done You might want to run 'apt-get -f install' to correct these: The following packages have unmet dependencies: google-chrom...
fragte user765883 vor 3 Jahren

0
Bewertungen
1
Antwort
140
Ansichten

Es können keine Apps mit dem Befehl apt-get install installiert werden

Ich habe vor kurzem Debian 8 (Jessie) installiert und wenn ich versuche, eine App zu installieren, erscheint die Meldung: Ein Medienwechsel ist erforderlich. Bitte legen Sie die Diskette mit der Beschriftung 'Debian GNU / Linux 8.7.1_Jessie_-Official amd64 DVD Binary - 1 20170116-11: 01' ein, um fo...
fragte Madalina Cojanu vor 3 Jahren

0
Bewertungen
1
Antwort
515
Ansichten

Proftpd für die Verwendung von Standalone über apt-get konfigurieren?

Ist es möglich, Argumente an den Befehl zu übergeben apt-get install proftpd, sodass der sich ergebende Installationsprozess den "Stand-Alone" -Modus annimmt, ohne den Benutzer nach Informationen zu fragen? (Wenn nötig, können wir wahrscheinlich von der Quelle oder so kompilieren. Ich wollte nur seh...
fragte Patrick at work vor 3 Jahren