There are several different ways that applications can be automatically started on Mac OS X. Some applications install some of their components, which may themselves be executable, in locations other than the main application folder. Tracking these down can be somewhat difficult if you don't know they exist, but once you do it's reasonably straightforward.
If the application doesn't have a built-in uninstall option, then you're left with tracking down the files and startup detritus. You can use the handy GUI application:
/Applications/Utilities/Activity Monitor
- Launch the Activity Monitor, then select the process of interest;
- click the blue (i) button to inspect it;
- select the Open Files and Ports tab;
then click the "Sample" button to get a list of open files used by the process, which should show you its configuration and startup files, as well as the application executable itself, and potentially many other files).
% lsof
If you prefer a UNIX command line, you can use the unix command lsof
in a Terminal.app shell window. (Google lsof
examples for details on lsof
).
Other handy tips:
When you find the application configuration file, read it. This may have hints which will help you track down the non-typical locations of application components.
See if the application has a log file, and look in that log file or in the system log for hints about the location of startup configuration or files. Use the Console.app, or poke around in the directories and files with the unix command line. Most application logs will be in one of these places, on Mac OS X Mountain Lion.
- ~/Library/Logs
- /Library/Logs
- /var/log
Knowing a little about the various startup methods can help you, too. Keywords to help in Google searches:
- cron ("crontab -l" in a Terminal.app window, to show a user's crontab)
- launchd ("launchctl list" in a Terminal.app window to show a list)
- SystemStarter (deprecated, the binary is not present on Mountain Lion)
Some but probably not all locations where startup scripts or configuration files may be found:
- /System/Library/LaunchAgents
- /System/Library/LaunchDaemons
- /Library/LaunchDaemons
- /Library/LaunchAgents
- ~/Library/LaunchAgents
- /Library/StartupItems
- /System/Library/StartupItems
- ~/Library/StartupItems