Computer kann nicht gestartet werden, nachdem Client Hyper-V aktiviert wurde

781
malan

Ich habe einen CyberPowerPC mit einem Intel-Chip, der Virtualisierung unterstützt. Mir fiel auf, dass VirtualBox mit GUI-Virtual Machines etwas träge ist. Daher entschied ich mich, Client Hyper-V zu aktivieren, um zu sehen, ob das besser funktioniert. Ich bin hier den Anweisungen der Powershell gefolgt . Nach dem Neustart kam mein Computer nicht am Dreipunktrad vorbei, bevor ein schwarzer Bildschirm aufgerufen und ein Neustart durchgeführt wurde.

Anschließend fand ich einen Wiederherstellungs-Startbildschirm, mit dem ich im abgesicherten Modus starten konnte. Ich habe die Power-Shell des abgesicherten Modus zum Deaktivieren von Client Hyper-V verwendet. Beim Neustart ging das System in den Normalmodus zurück, ohne dass ich es erneut aktivieren musste (ich denke, das ist das Standardverhalten?) Und konnte trotzdem nicht booten.

Ich habe überprüft, ob die Virtualisierung in UEFI aktiviert war. Ich habe versucht, es zu deaktivieren. Immer noch nicht gut.

Nach dem Versuch, in den abgesicherten Modus zurückzukehren, ging der Computer direkt zu einem Neustart-Bildschirm und jetzt bin ich wieder im Normalmodus.

Bitte helfen Ich weiß nicht einmal, wie ich konsequent in den sicheren Modus komme. Ich kann einen Anmeldebildschirm nicht erreichen, es sei denn, er befindet sich im abgesicherten Modus, und ich weiß nicht, wie ich den abgesicherten Modus dauerhaft erreichen kann. Mein Chef ist im anderen Raum und weiß nicht, welche Schwierigkeiten ich habe. Mein Magen liegt mir im Hals. Panik

Im Moment bin ich im abgesicherten Modus und versuche eine Datensicherung.

UPDATE: Weitere Daten: Prozessor Intel Core i7-3820 bei 3.60 GHz, 16 GB Ram, 64-Bit Windows 10 Pro

Problem: Client Hyper-V über PowerShell aktiviert und bei Aufforderung neu gestartet. Der Startvorgang erreicht den Punktkreis-Ladebildschirm, bevor er schwarz wird und in der Neustartschleife automatisch neu gestartet wird.

Fehlerbehebung Durchgeführte Schritte: 1) Im abgesicherten Modus gebootet, Client Hyper-V über PowerShell deaktiviert. Wird nach Aufforderung neu gestartet. Im normalen Modus gebootet. Ergebnis: Der Punktkreis-Ladebildschirm wird weiterhin in eine schwarze Auto-Neustart-Schleife geschnitten.

2) Deaktivierte Virtualisierung in UEFI. Ergebnis: Gleiches

3) Reaktivierte Virtualisierung in UEFI. Ergebnis: Gleiches

4) Im abgesicherten Modus gestartet, um alle Daten zu sichern. Hyper-V wird im Menü "Windows-Funktionen ein- / ausschalten" nicht markiert.

UPDATE2: In msconfig.exe ist mir aufgefallen, dass es mehrere Dienste gibt, die mit Hyper-V bezeichnet werden. Ich habe alle deaktiviert und einen normalen Startvorgang durchgeführt. Ergebnis: gleich.

0
Hast du zufällig ein Gigabyte-Motherboard? Einige Leute hatten das gleiche Problem, nachdem sie Hyper-V aktiviert hatten. Durch das Deaktivieren des USB3-Controllers im BIOS wurde das Bootproblem behoben. Selbst wenn Sie kein Gigabyte-Motherboard haben, ist es vielleicht einen Versuch wert. DrZoo vor einem Jahr 0
Ich bin nicht sicher, was das Motherboard ist. Nur zur Klarstellung: In UEFI habe ich die Option "Legacy USB 3.0 Support" und habe sie jetzt deaktiviert. Die UEFI sagt ASUS. malan vor einem Jahr 0
Problem wurde durch Deaktivieren der Option "Legacy USB 3.0 Support" in UEFI nicht behoben. malan vor einem Jahr 0
Ich bin mir nicht sicher, ob es die Legacy-Option wäre oder was. Ich muss das BIOS anschauen. Davon abgesehen haben Sie ein ASUS-Motherboard und kein Gigabyte. DrZoo vor einem Jahr 0
Wie melden Sie sich auf einem UEFI-Computer im BIOS an? Gibt es ein BIOS auf einem UEFI-Computer? Ich dachte, UEFI sei ein Ersatz für das BIOS. malan vor einem Jahr 0
Es ist, aber viele nennen es immer noch BIOS. Sie haben die Virtualisierung (VT-x oder VT-d) richtig aktiviert? Ich denke, Sie hätten das vor der Verwendung von VirtualBox tun müssen, aber ich bin mir nicht ganz sicher. DrZoo vor einem Jahr 0
Ja. Virtualisierung ist aktiviert. Ich habe gerade die Legacy USB3.0 Option wieder aktiviert. Ich störe in den UEFI / BIOS-Einstellungen. Es scheint mir, als könnte es alles sein. Zwei Gedanken, die ich hatte: Meine Firmware ist veraltet und / oder ich habe einen Grafikchip von schlechter Belüftung gebraten (die Position des Computers ist für mich eine Zeit lang lästig: er ist auf beiden Seiten geschlossen (wenn auch völlig offen) oben, vorne und hinten und etwa einen halben Meter vom Teppichboden entfernt. Ein Thema bei all dem ist: Ich weiß nicht einmal, wie ich die Firmware aktualisieren soll. malan vor einem Jahr 0

2 Antworten auf die Frage

1
harrymc

Versuchen Sie, mit diesem Verfahren den Status von Windows wiederherzustellen.

  1. Starten Sie im Wiederherstellungsmodus oder versuchen Sie dreimal, um die automatische Reparatur auszulösen
  2. Klicken Sie auf Advanced Startup
  3. Klicken Sie auf " Problembehandlung"
  4. Klicken Sie auf Erweiterte Optionen
  5. Klicken Sie auf Systemwiederherstellung
  6. Klicken Sie auf Weiter
  7. Wählen Sie den zuletzt bekannten funktionierenden Wiederherstellungspunkt
  8. (Optional) Klicken Sie auf die Schaltfläche Nach betroffenen Programmen suchen, um die Anwendungen anzuzeigen, die entfernt werden, wenn sie nach dem Erstellen des Wiederherstellungspunkts installiert werden
  9. Klicken Sie auf Schließen
  10. Klicken Sie auf Weiter
  11. Klicken Sie auf Fertig stellen
  12. Starten Sie neu.

image

Ich habe gerade die Systemwiederherstellung an einem Punkt von heute morgen eingeleitet, an dem die Windows-Modul-Installation (oder die Umgebung) erwähnt wurde, die für mich einen Wiederherstellungspunkt impliziert, der kurz vor der Installation von Hyper-V erstellt wurde. Wenn das nicht funktioniert, kann ich es noch am vorherigen Morgen von gestern morgen versuchen, in dem "Critical System Update" heißt. malan vor einem Jahr 0
Systemwiederherstellungspunkt konnte das Problem nicht beheben. Wird jetzt einen anderen Wiederherstellungspunkt versuchen. Wenn das Problem auch nicht behoben werden kann, weist dies auf ein Hardwareproblem hin? Ist es möglich, dass der Versuch, hyper-v gebratenes etwas zu ermöglichen? malan vor einem Jahr 0
Mit Computer "Wissenschaft" ist alles möglich. Wenn nichts funktioniert, müssen Sie [Startup Repair] (https://www.howtogeek.com/howto/7728/troubleshot-startup-problems-mit-startup-repair-tool-in-windows-7-vista/) durchführen. ). harrymc vor einem Jahr 0
Die zweite Systemwiederherstellung zu dem gestern erstellten Punkt konnte das Problem ebenfalls nicht beheben. Startup-Reparatur sagt, dass "Startup Repair Ihren PC nicht reparieren konnte." Es heißt, es gibt ein Logfile. Starten Sie im abgesicherten Modus, um es zu überprüfen. Warten. Mist Ich habe vergessen, den Ort aufzuschreiben. malan vor einem Jahr 0
Haben Sie einen Tipp, wo Sie in den Protokollen nach dem Problem suchen können? Ich sehe eine Menge Fehler für heute unter Systemprotokoll aus DistributedCOM-Fehler: "DCOM hat Fehler" 1084 beim Versuch, den Dienst CarboniteService zu starten ". Wie buchstäblich Tausende von ihnen, wahrscheinlich 20 pro Sekunde. malan vor einem Jahr 0
Haben Sie Carbonite Backup installiert? Wenn ja, versuchen Sie es zu deinstallieren. harrymc vor einem Jahr 0
Ja, ich habe Carbonite Backup installiert. Glaubst du, das könnte das Problem sein? Eine Art Kollision zwischen Hyper-v und Karbonit, die auch nach einer erneuten Deaktivierung von Hyper-v bestehen bleibt? Versuchen Sie die Deinstallation malan vor einem Jahr 0
0
J. Scott Elblein

Hast du das jemals geklärt? Ich bin gerade auf das Problem gestoßen, als ich versuchte, Docker in Windows 10 x64 auszuführen ...

Es ist definitiv von Hyper-V verursacht, aber ich habe noch nicht genau herausgefunden, warum oder wie man es beheben kann. Was ich in der Zwischenzeit immer noch gefunden habe, um in Windows booten zu können ( nicht nur im abgesicherten Modus und natürlich ohne dass Hyper-V einmal gebootet werden kann ), ist, Hyper-V über Ihre BCD-Datei auszuschalten.

Sie müssen jedoch in der Lage sein, zu einer Befehlszeile zu gelangen. Was ich getan habe, ist zu warten, bis die Startreparatur fehlgeschlagen ist, und dann im abgesicherten Modus zu starten. Von dort öffne ich eine erhöhte (Admin) Befehlszeile und tippe Folgendes:

BCDedit /set hypervisorlaunchtype Off 

Dann neu starten.

Wenn Sie mehr als einen Artikel in Ihrem BCD hatten, müssen Sie möglicherweise angeben, welcher Artikel den Hypervisor ausschalten soll. Sie können alle BCD-Elemente anzeigen, indem Sie Folgendes eingeben:

BCDEdiit 

Um das zu ändernde Element anzugeben, fügen Sie einfach seine ID hinzu:

BCDedit /set {<long string of numbers here>} hypervisorlaunchtype Off 

HINWEIS: Bei der Installation von Hyper-V wird dieses Flag in Ihrer BCD anscheinend automatisch auf "Auto" (Ein) gesetzt, wodurch die BSOD / Boot-Reparaturschleife verursacht wird. Wenn Sie das Problem behoben haben, müssen Sie dieses Flag wieder auf "Auto" setzen, um Hyper-V erneut verwenden zu können. Ich habe immer 2 Startoptionen in meiner BCD. eines mit aktiviertem Hyper-V, eines mit deaktiviertem. Dann wähle ich den gewünschten aus.