Styles werden mit XAMPP nicht in den virtuellen Host geladen

121
user1987003

Ich muss über mein Telefon auf ein Projekt zugreifen. Ich habe einen virtuellen Host so eingestellt:

<VirtualHost project.pp:80> ServerAdmin webmaster@localhost DocumentRoot C:/xampp/htdocs/project.pp ServerName project.pp  <Directory "C:/xampp/htdocs/project.pp"> Options Indexes FollowSymLinks Includes ExecCGI AllowOverride All Order allow,deny Allow from all </Directory> 

Beim Zugriff über das Telefon kann ich auf das Projekt zugreifen http://192.168.1.13/project.pp, die Stile und Skripts werden jedoch nicht geladen. Die Stile werden zu Beginn in meiner PHP-Datei mit einem Schrägstrich importiert. Dies ist beim Zugriff auf den PC, auf dem XAMPP installiert ist, gut geeignet. Wenn ich den Schrägstrich entferne, sind die Stile in Mobile OK.

Wenn ich beispielsweise versuche, auf eine andere Seite zuzugreifen /products, wird die URL angezeigt. http://192.168.1.13/productsDiese existiert nicht. Es entfernt meinen vhost.

Wie kann ich meinen vhost so einstellen, dass die Stile und meine sauberen URLs funktionieren?

Übrigens, das .htaccessist so konfiguriert:

RewriteEngine on Options -Indexes RewriteRule ^products/?$ ./products.php [NC,L] 
0
Natürlich funktioniert `/ products` nicht, da die Seite eine Erweiterung wie` / products.php` oder `/ products.pp` hat rlb.usa vor 2 Jahren 0
Ich kann mich nicht erinnern, wie XAMPP seine virtuellen Verzeichnisse einrichtet, aber im Wesentlichen geht es bei Ihrer Frage um Relative Paths. Vielleicht möchten Sie andere Fragen wie https://stackoverflow.com/questions/7823260/xampp-relative-urls-not-working-correctly oder https://stackoverflow.com/questions/9247949/xampp-local in Betracht ziehen -Installationsdatei-Pfad-Probleme rlb.usa vor 2 Jahren 1
Ist Ihre Frage nach Stilen oder handelt es sich um Regeln zum Umschreiben von URLs? Wenn es darum geht, Regeln umzuschreiben, dann sagen Sie es deutlich. Wenn dies nicht der Fall ist, dann sprechen Sie nicht darüber, wie, wenn Sie "Produkte" sagen, es gibt Ihnen "Produkte" statt dem, was Sie erwartet haben. Scott vor 2 Jahren 0
Der Stilteil war ein Test. Alle URLs, die ich mit einem "/" beginne, gehen zu meinem localhost und nicht zu meinem vhost, während in meinem PC xampp funktioniert, der ok ist. user1987003 vor 2 Jahren 0

0 Antworten auf die Frage